Error ‘SPSearch ([accountname]) when trying to activate WSS Search

I ran into the error shown below when I tried to activate WSS Search on my development server:  When examining the WSS Log file, I found the following error:

The call to SPSearchServiceInstance.Provision (server ‘[servername]’) failed. Setting back to previous status ‘Disabled’. System.ComponentModel.Win32Exception: SPSearch (mossadmin) at Microsoft.SharePoint.Win32.SPAdvApi32.ChangeServiceConfiguration(String strServiceName, String strAccountName, SecureString sstrPassword, IdentityType identityType, Boolean bDontRestartService) at Microsoft.SharePoint.Administration.SPProvisioningAssistant.ProvisionProcessIdentity(String strUserName, SecureString secStrPassword, IdentityType identityType, Boolean isAdminProcess, Boolean isWindowsService, String strServiceName, Boolean dontRestartService) at Microsoft.SharePoint.Administration.SPProcessIdentity.ProvisionInternal(SecureString sstrPassword, Boolean isRunningInTimer) at Microsoft.SharePoint.Administration.SPProcessIdentity.Provision() at Microsoft.SharePoint.Administration.SPWindowsServiceInstance.ProvisionCredentials() at Microsoft.SharePoint.Administration.SPWindowsServiceInstance.Provision(Boolean start) at Microsoft.SharePoint.Administration.SPWindowsServiceInstance.Provision() at Microsoft.SharePoint.Search.Administration.SPSearchServiceInstance.Provision() at Microsoft.SharePoint.Search.Internal.UI.SPSearchServiceInstanceSettings.BtnSubmit_Click(Object sender, EventArgs args)

After fiddeling around with the settings, I figured out that you must enter the name of the service and content accounts in the format [SERVERNAME]\[AccountName].

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>